I am able to start dbsrv12 with Web by Windows7 without facing problem but Ubuntu 12.10 I have downloaded SQLAny12, Web SQLAny12 and SQLAny16, all not able to start with -xs option

-xs HTTP also not able to start. Could not bind to address (::):80 since no IP address, I specify HOST=IP address also same error unexpected token `('

  • I am able to start without using -xs option
  • I already execute sa_config.sh and double confirm environment variable is set.
  • I have tested double quotation when I specify option but still error.

asked 26 Mar '13, 01:26

Ukraine's gravatar image

Ukraine
76336
accept rate: 0%

edited 26 Mar '13, 08:52

Mark%20Culp's gravatar image

Mark Culp
22.7k9129266

3

When you say you've "tested double quotation", what exactly did you use? Update your question to include the exact command. Feel free to mask passwords or IP addresses (use a.b.c.d) if you wish but we need to see exactly what you entered.

(26 Mar '13, 08:46) Graeme Perrow

Thomas is correct: round brackets are interpreted by Bash. You need to quote around the bracketed argument:

 dbsrv12 demo.db -xs "http(port=80)"

However, if this still isn't working for you, you can also alternatively use curly brackets without quoting:

 dbsrv12 demo.db -xs http{port=80}
permanent link

answered 26 Mar '13, 12:00

Jeff%20Albion's gravatar image

Jeff Albion
10.7k171174
accept rate: 24%

I'm sorry I didn't use Linux for while due to some testing I am able to execute demo.db without -xs option, environment variable is OK

dbsrv12 demo.db -xs "http(port=80)" dbsrv12 demo.db -xs http{port=80} dbsrv12 demo.db -xs "http{port=80}"

ERROR show Could not bind to address (::):80 Can't start HTTP listener on address (::):80 Database server shutdown due to startup error TCPIP listener on IP address (::):2638 is exiting TCPIP listener on IP address 0.0.0.0:2638 is exiting

(31 Mar '13, 22:51) Ukraine

I have tested to specify HOST by -x option but Unknow option "HOST" For Unix, quotation marks are required if more than one parameter is supplied: dbsrv12 demo.db -xs http{port=80} -x "tcpip{HOST=192.168.1.10;PORT=80}" I have tested dbsrv12 demo.db -xs http{port=80} -x "tcpip{MyIP=192.168.1.10;PORT=80}" it show Trying to start TCPIP link ... TCPIP communication link not started Unable to initialize requested communication links

(31 Mar '13, 23:35) Ukraine
Replies hidden

sorry MyIP=192.168.1.10;PORT=2638

(01 Apr '13, 02:14) Ukraine
2

If you are trying to use a port less than 1000 on Unix (including Linux) then you must be running the server as root. Ports < 1000 are restricted on Unix to be only available to root user.

(01 Apr '13, 08:20) Mark Culp

The Shell Bash is interpreting your Command line. Try to use double Quotes around the Parameter.

Kind Regards

permanent link

answered 26 Mar '13, 07:04

Thomas%20Duemesnil's gravatar image

Thomas Dueme...
2.5k213460
accept rate: 15%

as I mentioned I have tested double quotation when I specify option I refer to manual it show several way, I have tested. I didn't try single quotation

(26 Mar '13, 08:07) Ukraine

As Graeme suggested, please show us the complete statment you're trying to execute. That would allow answers to be more than guesswork.

(27 Mar '13, 05:14) Reimer Pods
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×61
×13
×5

question asked: 26 Mar '13, 01:26

question was seen: 4,272 times

last updated: 01 Apr '13, 08:20