Hi

I am trying to configure relay server my QA server. I've followed the config guide and updated the Apache configuration correctly. I am able to start Apache and relay server without any issue however when I trying to access the relay server it giving http 500 errors.

[03/Dec/2012:19:22:01 -0800] "GET /srv/iarelayserver/mod_rs_ap_server.so HTTP/1.1" 500 515
10.31.17.145 - - [03/Dec/2012:19:31:25 -0800] "GET /srv/iarelayserver/mod_rs_ap_server.so HTTP/1.1" 500 515
10.31.17.145 - - [03/Dec/2012:19:31:26 -0800] "GET /srv/iarelayserver/mod_rs_ap_server.so HTTP/1.1" 500 515
10.31.17.145 - - [03/Dec/2012:19:31:27 -0800] "GET /srv/iarelayserver/mod_rs_ap_server.so HTTP/1.1" 500 515
10.31.17.145 - - [03/Dec/2012:19:31:27 -0800] "GET /srv/iarelayserver/mod_rs_ap_server.so HTTP/1.1" 500 515
10.31.17.145 - - [03/Dec/2012:19:31:27 -0800] "GET /srv/iarelayserver/mod_rs_ap_server.so HTTP/1.1" 500 515
10.31.17.145 - - [03/Dec/2012:19:31:27 -0800] "GET /srv/iarelayserver/mod_rs_ap_server.so HTTP/1.1" 500 515

Did anyone faced similar issue. my relay server config is Redhat linux and Apache 2.2.23

Thanks in advance for your inputs

Thanks Naga

asked 03 Dec '12, 22:53

naga28's gravatar image

naga28
1111
accept rate: 0%

edited 04 Dec '12, 08:50

Reg%20Domaratzki's gravatar image

Reg Domaratzki
5.2k33575

I think you might be specifying the incorrect URL suffix when trying to connect your RSOE.

I would expect the -cr switch on the rsoe to look someting like the following when using Apache :

-cr "host=rdomarat-rs1201;port=80;url_suffix=/srv/iarelayserver"

I suspect your url_suffix also includes mod_rs_ap_server.so, which is not needed.

If this is not the issue, then can you please post the changes your have made to the Apache httpd.conf file and also post the start line for the rsoe that is failing to connect. Just to be on the safe side, please also post the Apache error_log, as well as verbosity 5 logs from both the Relay Server and the RSOE when the errors occur.

(04 Dec '12, 08:59) Reg Domaratzki
Replies hidden

I hadn't heard a response yet, so in case you're in a time zone such that we never work the same hours, I asked for more information by editing answer.

(04 Dec '12, 16:42) Reg Domaratzki

Hi Reg Domaratzki,

Sorry for late reply. Please find apache changes I've made in http.conf file.

LoadModule iarelayserver_client_module modules/mod_rs_ap_client.so
LoadModule iarelayserver_server_module modules/mod_rs_ap_server.so

909a914,922
<LocationMatch /cli/iarelayserver/* >
       SetHandler iarelayserver-client-handler
 </LocationMatch>

 <Location /srv/iarelayserver/* >
     SetHandler iarelayserver-server-handler
     RSConfigFile "/etc/httpd/modules/modules/rs.config"
 </Location>
(04 Dec '12, 16:49) naga28
Comment Text Removed

I had initally asked for the changes to the httpd.conf file and the start line for the RSOE that is failing. A later edit (which you likely missed given the time your responded) also asked for the Apache error_log and verbose output from the Relay Server and the RSOE. Can you provide this information as well please?

(04 Dec '12, 16:57) Reg Domaratzki

Apache error

[Mon Dec 03 19:09:12 2012] [error] [client 10.31.17.145] Directory index forbidden by Options directive: /var/www/html/
[Mon Dec 03 19:16:59 2012] [notice] caught SIGTERM, shutting down
[Mon Dec 03 20:18:51 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Mon Dec 03 20:18:51 2012] [notice] Digest: generating secret for digest authentication ...
[Mon Dec 03 20:18:51 2012] [notice] Digest: done
[Mon Dec 03 20:18:51 2012] [notice] Apache/2.2.3 (Red Hat) configured -- resuming normal operations
[Mon Dec 03 20:19:19 2012] [error] [client 10.31.17.145] Directory index forbidden by Options directive: /var/www/html/
[Mon Dec 03 20:23:26 2012] [error] [client 10.31.17.145] Error parsing config file on the Relay Server, pid: 3291
[Mon Dec 03 20:33:59 2012] [error] [client 10.31.17.145] Error parsing config file on the Relay Server, pid: 3292


RSOE Logs

I. 2012-12-04 14:11:05. iAnywhere Outbound Enabler Version 12.0.1.3726
I. 2012-12-04 14:11:05. 
I. 2012-12-04 14:11:05. Copyright © 2001-2012, iAnywhere Solutions, Inc.
I. 2012-12-04 14:11:05. Portions copyright © 1988-2012, Sybase, Inc. All rights reserved.
I. 2012-12-04 14:11:05. Use of this software is governed by the Sybase License Agreement.
I. 2012-12-04 14:11:05. Refer to http://www.sybase.com/softwarelicenses.
I. 2012-12-04 14:11:05. 
I. 2012-12-04 14:11:05. <OEHost> 
I. 2012-12-04 14:11:05. <OEHost> iAnywhere Outbound Enabler Version 12.0.1.3726
I. 2012-12-04 14:11:05. <OEHost> Machine PA-MOBILE-QA01 is running Windows 2008R2 Build 7601 Service Pack 1
I. 2012-12-04 14:11:05. <OEHost> Software built for X86_64
I. 2012-12-04 14:11:05. <OEHost> Time zone offset from UTC in minutes: -480
I. 2012-12-04 14:11:05. <OEHost> 
I. 2012-12-04 14:11:06. <OEMaster> Successfully connected to backend server: localhost:5001

(04 Dec '12, 17:14) naga28

The apache log now indicates that there is an error parsing the config on the Relay Server. Can you post the contents of the config file?

(06 Dec '12, 07:54) Reg Domaratzki

Here is the content of my rs config file.

#-----
# Template Relay Server configuration file based on cluster information
#-----

#-------------------------------------
# Relay server Options
#-------------------------------------
[options]
start = no
verbosity = 1
# Note: When auto start is used, the default log file is
#       %temp%\ias_relay_server_host.log while rshost is active and it will
#       be renamed using YYMMDDNN.olg filename format upon shutdown.

#--------------------
# Relay server peers
#--------------------
[relay_server]
enable          = yes
host            = 132.190.15.114
http_port       = 80
https_port      = 443
description     = Relay server for Dev
#---------------
# Backend farms - RBS
#---------------
#---------------
# Backend farm - RBS 
#---------------
[backend_farm]
enable          = yes
id              = pa-mobile-dev.rep
#client_security = on
#backend_security= on
description     = Unwired Server Farm auto-generated by quick configuration.
#-----------------
# Backend servers - RBS 
#-----------------
[backend_server]
enable   = yes
farm     = pa-mobile-dev.rep
id       = pa-mobile-dev-rep-pa-mobile-dev1
# uncomment mac if you want Relay Server to do MAC verification.
# the value should have only the 1 MAC address RSOE sends to relay server.
# Look in the RSOE.log file to see what that address is
#mac      = 00-00-00-00-00-00-00-e0!!00-00-00-00-00-00-00-e0!!00-50-56-be-00-ef
token    = devrbs
[backend_server]
enable   = yes
farm     = pa-mobile-dev.rep
id       = pa-mobile-dev-rep-pa-mobile-dev2
# uncomment mac if you want Relay Server to do MAC verification.
# the value should have only the 1 MAC address RSOE sends to relay server.
# Look in the RSOE.log file to see what that address is
#mac      = 00-00-00-00-00-00-00-e0!!00-00-00-00-00-00-00-e0!!00-50-56-be-00-ef
token    = devrbs
[backend_server]
enable   = yes
farm     = pa-mobile-dev.rep
id       = pa-mobile-dev-rep-pa-mobile-dev3
# uncomment mac if you want Relay Server to do MAC verification.
# the value should have only the 1 MAC address RSOE sends to relay server.
# Look in the RSOE.log file to see what that address is
#mac      = 00-00-00-00-00-00-00-e0!!00-00-00-00-00-00-00-e0!!00-50-56-be-00-ef
token    = devrbs
#-------------------------
# Backend farms - MBS 
#-------------------------
#-------------------------
# Backend farm - MBS 
#-------------------------
[backend_farm]
enable          = yes
id              = pa-mobile-dev.msg
client_security = off
#backend_security= on
description     = Unwired Server Farm auto-generated by quick configuration.
#---------------------------
# Backend servers - MBS
#---------------------------
[backend_server]
enable   = yes
farm     = pa-mobile-dev.msg
id       = pa-mobile-dev-msg-pa-mobile-dev1
# uncomment mac if you want Relay Server to do MAC verification.
# the value should have only the 1 MAC address RSOE sends to relay server.
# Look in the RSOE.log file to see what that address is
#mac      = 00-00-00-00-00-00-00-e0!!00-00-00-00-00-00-00-e0!!00-50-56-be-00-ef
token    = devmbs
[backend_server]
enable   = yes
farm     = pa-mobile-dev.msg
id       = pa-mobile-dev-msg-pa-mobile-dev2
# uncomment mac if you want Relay Server to do MAC verification.
# the value should have only the 1 MAC address RSOE sends to relay server.
# Look in the RSOE.log file to see what that address is
#mac      = 00-00-00-00-00-00-00-e0!!00-00-00-00-00-00-00-e0!!00-50-56-be-00-ef
token    = devmbs
[backend_server]
enable   = yes
farm     = pa-mobile-dev.msg
id       = pa-mobile-dev-msg-pa-mobile-dev3
# uncomment mac if you want Relay Server to do MAC verification.
# the value should have only the 1 MAC address RSOE sends to relay server.
# Look in the RSOE.log file to see what that address is
#mac      = 00-00-00-00-00-00-00-e0!!00-00-00-00-00-00-00-e0!!00-50-56-be-00-ef
token    = devmbs
(06 Dec '12, 16:51) naga28
showing 1 of 7 show all flat view

There doesn’t seem to anything wrong with the rs.config file, and I still haven’t seen a lot of the information that I asked for. The logs appear to have different timestamps on them, so it’s not clear to me whether errors I see in the logs are still valid, or whether they are issues you’ve now moved past. I'm going to ask for all the information we need at once, so we can a nice clean snapshot of the environment as it is today.

To begin, we’d like higher verbosity on the log files for the relay server and rsoe. Please edit the rs.config file to increase the verbosity to 5 in the “[options]” section, and change the start line for the outbound enable to include “-v 5”.

On the machine where Apache is running, please gather the following information:

  1. How is Apache started? Do you start the process manually, or is it started as a service?
  2. Please provide the httpd.conf file for the Apache server.
  3. How is the rshost process started? I can see that the rs.config file contains “start=no”. Do you start rshost as a service on the machine? If so, please provide information on the service, particularly the user that the service runs as. Do you start rshost manually? If so, what command line do you use and what user are you logged in as when you start the process?
  4. Please provide the rs.config file used by the rshost process.

On the machine where the Outbound Enabler (rsoe) is running, please gather the following information:

  1. How is the Outbound Enabler started? Is it started manually, or as a service?
  2. Please provide the start line for the Outbound Enabler. If the start line includes “@filename”, please provide the contents of “filename” as well.

Once the information above has been gathered, please perform a quick test.

  1. Shut down the outbound enabler.
  2. Re-start the rshost process to ensure that the changes to the rs.config file to increase the verbosity are active
  3. Re-start the outbound enabler, ensuring that you have added “-v 5” to the start line.

At this point, gather the verbose logs from the Relay Server (rshost) and Outbound Enabler (rsoe), and the access_log and error_log from the Apache Server. Tar these files (as well as the httpd.conf and rs.config file we’d asked for earlier) and post the file to the forum (or e-mail them to me). Please also include the information about the Apache Server, rshost and rsoe are started when you send the files.

Thanks, Reg

permanent link

answered 07 Dec '12, 11:43

Reg%20Domaratzki's gravatar image

Reg Domaratzki
5.2k33575
accept rate: 41%

There doesn’t seem to anything wrong with the rs.config file, and I still haven’t seen a lot of the information that I asked for. The logs appear to have different timestamps on them, so it’s not clear to me whether errors I see in the logs are still valid, or whether they are issues you’ve now moved past. I'm going to ask for all the information we need at once, so we can a nice clean snapshot of the environment as it is today. To begin, we’d like higher verbosity on the log files for the relay server and rsoe. Please edit the rs.config file to increase the verbosity to 5 in the “[options]” section, and change the start line for the outbound enable to include “-v 5”. On the machine where Apache is running, please gather the following information: 1. How is Apache started? Do you start the process manually, or is it started as a service? I am starting apache manually 2. Please provide the httpd.conf file for the Apache server. Attached the config file 3. How is the rshost process started? I can see that the rs.config file contains “start=no”. Do you start rshost as a service on the machine? If so, please provide information on the service, particularly the user that the service runs as. Do you start rshost manually? If so, what command line do you use and what user are you logged in as when you start the process? I am starting manually, I am still configuring the relay server. after successful configuration I will add it as a linux demon 4. Please provide the rs.config file used by the rshost process. Attached

On the machine where the Outbound Enabler (rsoe) is running, please gather the following information: 1. How is the Outbound Enabler started? Is it started manually, or as a service? Startup process configured as services 2. Please provide the start line for the Outbound Enabler. If the start line includes “@filename”, please provide the contents of “filename” as well. Once the information above has been gathered, please perform a quick test. 1. Shut down the outbound enabler. 2. Re-start the rshost process to ensure that the changes to the rs.config file to increase the verbosity are active 3. Re-start the outbound enabler, ensuring that you have added “-v 5” to the start line. At this point, gather the verbose logs from the Relay Server (rshost) and Outbound Enabler (rsoe), and the access_log and error_log from the Apache Server. Tar these files (as well as the httpd.conf and rs.config file we’d asked for earlier) and post the file to the forum (or e-mail them to me). Please also include the information about the Apache Server, rshost and rsoe are started when you send the files. Attached.

Please download log files using links below as site allowing me to upload files. ftp://ftp.varian.com/outgoing/Sybase.zip

Thanks in advance for your time and help Reg Domaratzki. link text Thanks Naga

permanent link

answered 09 Dec '12, 22:09

naga28's gravatar image

naga28
1111
accept rate: 0%

Sorry for the delay, I was home sick on Monday and Tuesday.

It looks like you have attached the rshost executable, and not the rshost log file. Also, you have attached the httpd.pid file, and not the Apache configuration file (/etc/httpd/conf/httpd.conf).

Since both processes (Apache and rshost) are being started manually, can you please confirm that you are logged in as the same user when you start both processes?

You did not provide the start line for the rshost process either. Please provide the start line.

One idea, given the information that was provided :

Your Apache error log continues to say there are errors in your rs.config file, but your config file is fine (I can start an rshost and parse your config file). Does the rshost process have permission to read the rs.config file?

Reg

(12 Dec '12, 10:24) Reg Domaratzki
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×11

question asked: 03 Dec '12, 22:53

question was seen: 1,157 times

last updated: 12 Dec '12, 10:24