I have a server defined locally under XP running 12.0.1.3726 which starts on the startup. When I add a new ODBC entry with the ODBC Administrator tool for a non-running db (setup as "Start and connect to a database on this computer"), the Test Connection feature is returning the SQL code -75 message:

    Connection failed: Request to start/stop database denied.

A DCX entry for SQLCODE = -75 shows:

    You do not have permission to start or stop a database. 
    The required permission is determined on the server command line.

Adding the server name does not help to have this local connection completed OK. All the connections to the running db's do test fine.
It seems that only after unloading the service the connection will then test successfully.

asked 19 May '12, 13:13

Derli%20Marcochi's gravatar image

Derli Marcochi
1.6k323877
accept rate: 33%

edited 19 May '12, 13:19

When creating a new entry with a 5.5 driver the server name is pre-filled with "<default>".

I added the same text in the server name of the ODBC entry created with the 12 driver and the connection is now testing fine. Is that a valid/acceptable solution?

(19 May '12, 16:48) Derli Marcochi

I have a situation with 32 and 64 bit ODBC connections for SQL Anywhere 11

The 32 bit connection (system DSN) is set to start automatically and the test connection works fine.

I created the same system DSN (settings are no different) for the 64 bit connection and get the first message above.

No database processes are running in the task manager. I can't get the 64 bit connection to connect.

(24 Apr '13, 10:17) scottchamilton

When running a network server (i.e. dbsrv12), autostarting of databases is disallowed by default. In order to start a database on a running network server, you need to either:

  1. Specify the -gd all switch on the server start line. This will allow any connection to start a new database on that server.
  2. Connect to a database already running on that server as a user with DBA authority and then execute the start database statement.

When you unload the service, the client cannot find a running server to connect to, so it starts its own using dbeng12. Autostarting database on personal servers is allowed by anyone by default, so the client can successfully start the database on that server.

permanent link

answered 19 May '12, 16:10

Graeme%20Perrow's gravatar image

Graeme Perrow
8.5k371109
accept rate: 52%

1

Breck and Graeme, After adding the -gd all parameter the local connection tested fine.

Regarding the <default> server name I entered as a comment, is it still a valid/documented solution for 12?

(19 May '12, 18:37) Derli Marcochi

Does the service setup specify dbsrv12.exe or dbeng12.exe?

If it is dbsrv12.exe, does the user id in the ODBC setup have DBA permissions?

If not, then try specifying -gd all -gk all in the service setup:

http://dcx.sybase.com/index.html#1201/en/saerrors/errm75.html

http://dcx.sybase.com/index.html#1201/en/dbadmin/gd-database-dbengine.html

http://dcx.sybase.com/index.html#1201/en/dbadmin/gk-database-dbengine.html

permanent link

answered 19 May '12, 16:00

Breck%20Carter's gravatar image

Breck Carter
25.6k427586844
accept rate: 20%

edited 19 May '12, 16:04

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×125
×124
×61

question asked: 19 May '12, 13:13

question was seen: 6,352 times

last updated: 24 Apr '13, 10:57