Hello,

we use smtp replication with dbremote 10.0.1.4239

Everything works smoothly, but now we did add a new remote to the replication and that one can't send back messages to the consolidate.

It always aborts with:

I. 2012-03-26 15:33:00. Nachricht wird an "outlet24" (0-0005534246-0005538674-0) gesendet
I. 2012-03-26 15:33:06. Line is too long, buffer overflow
I. 2012-03-26 15:33:11. Line is too long, buffer overflow
I. 2012-03-26 15:33:16. Line is too long, buffer overflow
I. 2012-03-26 15:33:21. Line is too long, buffer overflow
I. 2012-03-26 15:33:27. Line is too long, buffer overflow
E. 2012-03-26 15:33:32. Fehler beim Senden der Nachricht
I. 2012-03-26 15:33:32. Anforderungen erneuter Sendungen werden in die Warteschlange gesetzt
E. 2012-03-26 15:33:32. Senden von Nachrichten fehlgeschlagen
I. 2012-03-26 15:33:33. Ausführung abgeschlossen

The problem turns out to be a "transparent" smtp proxy which listens on port 25 of the ISP and then stumbles over the smtp traffic of dbremote. They have this in place to prevent sending spam from dialup/dsl connections, and state that we should use another port than port 25... On our server side the mailserver also accepts port 587 (submission)

We did already try to decrease the length to the minimum of 10000 (-l 10000) but to no avail....

Is there a way to have dbremote with SMTP to connect to port 587 of the smtp server (Submission port) ?

André

asked 26 Mar '12, 09:43

ASchild's gravatar image

ASchild
777222740
accept rate: 14%

edited 28 Mar '12, 03:33

Volker%20Barth's gravatar image

Volker Barth
31.3k312458674

The provider is swisscom in switzerland, (One of the largest providers in switzerland, market share ~50%)

(26 Mar '12, 09:44) ASchild
1

You can't change the port numer, but we'd be interested in seeing a dbremote log with debug settings on for the SMTP message link. Can you execute a command similar to :

set remote smtp option debug='on'

Thanks, Reg

(26 Mar '12, 16:08) Reg Domaratzki
Comment Text Removed

There seems to not be a way to format comments, so I put the debug=on messages as a answer....

(27 Mar '12, 12:24) ASchild
Replies hidden

FWIW: You can also format comments (w.t.h. of Markdown basics, cf. the right pane of the edit page...) - another approach is to write an answer and convert it into a comment afterwards (and possibly convert it back into an answer for further editing, though that may break nested comments).

Yep, this seems fitting to the port fix you needed to do:)

(27 Mar '12, 12:34) Volker Barth

Thank you for the feature request - I have opened an enhancement request support case and engineering case (#11728671 / CR #703130 respectively) for the options 'smtp_port' / 'pop3_port' ( http://dcx.sybase.com/index.html#1201/en/dbreference/set-remote-option-statement.html ) to be considered in a future release.

permanent link

answered 27 Mar '12, 18:45

Jeff%20Albion's gravatar image

Jeff Albion
10.7k171174
accept rate: 24%

dbremote uses the standard port 25 to talk to the SMTP server. This port is hard coded and you cannot change it. You may be able to solve this problem by redirecting the network traffic from port 25 to port 587 using Java or Perl script, but I have never done this before.

permanent link

answered 26 Mar '12, 12:40

Yufei%20Guo's gravatar image

Yufei Guo
401213
accept rate: 6%

You may be able to try setting remote options for the SMTP, as there are a few settings (haven't tested, just posting). I'm thinking specifically smtp_host, which might accept a port, not sure.

SET REMOTE OPTION

The SMTP Message System

permanent link

answered 26 Mar '12, 13:40

Calvin%20Allen's gravatar image

Calvin Allen
1.5k232638
accept rate: 25%

edited 26 Mar '12, 13:41

1

The "debug" option may be helpful, as well...

(26 Mar '12, 14:09) Volker Barth
1

The smtp_host option will not accept a port. Port 25 is hard coded into dbremote when using SMTP.

(26 Mar '12, 14:22) Reg Domaratzki

Here what the debug=on shows:

I. 2012-03-27 17:51:53. gethostname
I. 2012-03-27 17:51:53. gethostbyname pos-058
I. 2012-03-27 17:51:53. gethostbyname smtp.aarboard.ch
I. 2012-03-27 17:51:53. socket
I. 2012-03-27 17:51:53. connect SMTP
I. 2012-03-27 17:51:58. 220 zhhdzmsp-nwas16.bluewin.ch ESMTP Service (Swisscom Schweiz AG) ready
I. 2012-03-27 17:51:58. EHLO pos-058
I. 2012-03-27 17:51:58. 250-zhhdzmsp-nwas16 says EHLO to 81.62.119.19:55582
I. 2012-03-27 17:51:58. 250-PIPELINING
I. 2012-03-27 17:51:58. 250-8BITMIME
I. 2012-03-27 17:51:58. 250-SIZE 26214400
I. 2012-03-27 17:51:58. 250-AUTH=LOGIN
I. 2012-03-27 17:51:58. 250 AUTH LOGIN
I. 2012-03-27 17:51:58. Authentication mech found: LOGIN
I. 2012-03-27 17:51:58. AUTH LOGIN
I. 2012-03-27 17:51:58. 334 *********
I. 2012-03-27 17:51:58. **************
I. 2012-03-27 17:51:58. 334 *************
I. 2012-03-27 17:51:58. ***********
I. 2012-03-27 17:51:58. 235 Authed. Go on.
I. 2012-03-27 17:51:58. MAIL FROM:<xxxxxxxxxxx@yyyyyy.ch>
I. 2012-03-27 17:51:58. 250 MAIL FROM accepted
I. 2012-03-27 17:51:58. RCPT TO:<zzzzzzzzzzz@yyyyyyyyyyy.ch>
I. 2012-03-27 17:51:58. Line is too long, buffer overflow
I. 2012-03-27 17:51:58. RSET
I. 2012-03-27 17:51:58. ad of port 25. More information: www.swisscom.ch/p25.
I. 2012-03-27 17:51:58. QUIT
I. 2012-03-27 17:51:58. 250 RSET OK
I. 2012-03-27 17:51:58. closesocket

In the meantime I did install a local postfix which is then forwarding the mails to the smarthost on port 587, so this works.

But a option to tell dbremote to use another smtp port would highly be appreciated, since in switzerland many ISP's block port 25

permanent link

answered 27 Mar '12, 12:23

ASchild's gravatar image

ASchild
777222740
accept rate: 14%

edited 27 Mar '12, 14:11

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×114
×107
×44
×9
×8

question asked: 26 Mar '12, 09:43

question was seen: 1,932 times

last updated: 28 Mar '12, 03:33